1983 exa turbo - bayside blue and 81POLR!!!!

The place to introduce yourself, post photos and specs of your car.
robbo
Posts: 115
Joined: Tue Jul 03, 2012 3:39 pm
Location: Sydney

Post by robbo » Wed Aug 06, 2014 9:37 am

car runs, i'm pretty sure all leaks have been fixed other than the injector o rings lol

in a drama filled week off last week instead of going away on holidays with the mrs i stayed home and bought paint and sprayed the car bayside blue with plenty of blue pearl. pics to follow after buffing is completed shortly

Also purchased a rear whiteline sway bar!!!!!!!!!!!!!!!! and a pair of really comfy bucket seats and slotted rotors and bendix pads. Would like to say thanks to all my fellow n12 turbo enthusiasts for all the advice and discounts on parts to help me to getting the car to this point.

oh, and the car is currently being registered, and will have a blue slip by the weekend :D!!!!!!!!!!!

robbo
Posts: 115
Joined: Tue Jul 03, 2012 3:39 pm
Location: Sydney

Post by robbo » Fri Aug 15, 2014 1:42 pm

car passed blueslip first go but needs a bit more time to save up for rego, which will now be in two weeks from tomorrow when my custom plates arrive. 81POLR. lol

finally replaced the o rings on the injectors so now the car idles properly, should have everything installed tomorrow so just waiting on the wheels next wednesday, and then the plates/rego after that. so keen to drive it!!!

robbo
Posts: 115
Joined: Tue Jul 03, 2012 3:39 pm
Location: Sydney

Post by robbo » Thu Aug 28, 2014 4:09 pm

car is registered with its custom plates and has new wheels on it. waiting on the cash to replace the tyres, get the wheels aligned properly and rear suspension bushes done on one side so that it is safe to drive.... so tempting to drive it when it is on the road outside teasing me haha

robbo
Posts: 115
Joined: Tue Jul 03, 2012 3:39 pm
Location: Sydney

Post by robbo » Mon Sep 08, 2014 2:43 pm

car's booked into the mechanics in three days time to get four new re002 tyres, alignment and suspension checked, rear engine mount and slotted rotors installed. can't wait to drive it XD

robbo
Posts: 115
Joined: Tue Jul 03, 2012 3:39 pm
Location: Sydney

Post by robbo » Mon Sep 08, 2014 2:47 pm

Image

robbo
Posts: 115
Joined: Tue Jul 03, 2012 3:39 pm
Location: Sydney

Post by robbo » Tue Sep 16, 2014 9:31 am

car has been towed from two workshops twice in the last week, the diagnosis being fucked wheel bearings and a worn hub where it meets the brand new ball joint on the driver's side... Just told the workshop to reassemble the car with all new parts, except the hub which i need to get first. of all the things to break it has to be the most random thing i can't just find at repco lol

that said, cannot wait to drive it tonight after over a year off the road!!!!!!!!!

robbo
Posts: 115
Joined: Tue Jul 03, 2012 3:39 pm
Location: Sydney

Post by robbo » Fri Sep 19, 2014 3:42 pm

well the good news is that it drove ridiculously well and had all the power i could ask for... until it overheated on the freeway going home from a meet. another trip on the tow truck (3rd this fucking week) and will be spending time on the weekend trying to work out if i've done the head gasket or not. mrs says i am not allowed to spend a cent on it, fucking bs not happy jan

robbo
Posts: 115
Joined: Tue Jul 03, 2012 3:39 pm
Location: Sydney

Post by robbo » Tue Sep 23, 2014 9:17 am

got lucky, put an inspection cam down all the cylinders, no damage. turns out the battery was failing to put enough power to the starter motor so an easy fix in the end. Thanks to everyone on the fb group for the advice!!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest