Chassis hassle

General chat related to anything N12.
Post Reply
User avatar
Kimmo
Posts: 2285
Joined: Thu Nov 02, 2006 8:40 am
Location: Footscray

Chassis hassle

Post by Kimmo » Mon Dec 14, 2015 7:10 pm

Hi folks, been a while, eh :wink:

So something bad has happened; it feels like something's broken.

The car now pulls to the right under power, seems to lean more to the right than the left when cornering, and it feels kinda spooky and asymmetrically wrong when I hit big dips or humps at speed (80+).

I've just borrowed a jack and some axle stands from a mate - what do you guys reckon I should look for? I've already tried hauling on the wheels when I've jacked the car up, and I can't get any movement...

I was thinking maybe a broken swaybar mount or something, but that doesn't seem like enough to make it so spooky.

Halp! :shock:

15exa
Administrator
Administrator
Posts: 1012
Joined: Mon Aug 07, 2006 11:00 am
Location: brisbane

Post by 15exa » Mon Dec 14, 2015 11:12 pm

sway bar, control arm bushes, ball joint. but you would think there would be a decent clunking noise if they were clapped out to the point of such ill handling

User avatar
Kimmo
Posts: 2285
Joined: Thu Nov 02, 2006 8:40 am
Location: Footscray

Post by Kimmo » Tue Dec 15, 2015 2:07 pm

Had a good look underneath today, can't find anything : (

n12et_exa
Posts: 110
Joined: Sat Dec 17, 2011 1:45 pm

Re: Chassis hassle

Post by n12et_exa » Fri Jan 27, 2017 8:05 pm

Mine was doing the same thing replaced the wheel bearings and it fixed the issue

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests